Sample code in 'How to build applications with OpenCV inside the Microsoft Visual Studio' all wrong (Bug #3315)


Added by Tim Regan almost 2 years ago. Updated almost 2 years ago.


Status:Done Start date:2013-10-10
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:documentation
Target version:2.4.7
Affected version:2.4.7 (latest release) Operating System:Any
Difficulty:Easy HW Platform:Any
Pull request:https://github.com/Itseez/opencv/pull/1842

Description

The sample code in http://docs.opencv.org/trunk/doc/tutorials/introduction/windows_visual_studio_Opencv/windows_visual_studio_Opencv.html#windows-visual-studio-how-to linked to from http://opencv.org/quickstart.html purports to be a simple example loading and displaying an image, but in fact is a completely different piece of code.

For example the author invokes the sample with the single argument exampleImage.jpg either supplied on the command line or set in the Property Pages but the code itself first checks that argc is 5

http://answers.opencv.org/question/22235/what-are-the-five-arguments-in-the-how-to-build/


History

Updated by Tim Regan almost 2 years ago

I think it may just be a copy-and-paste error and the intended code was this instead:

https://github.com/Itseez/opencv/blob/master/samples/cpp/tutorial_code/introduction/display_image/display_image.cpp

Updated by Kirill Kornyakov almost 2 years ago

Could be... Could you work on a pull-request, since OpenCV has 0 technical writers at the moment? =)

  • Status changed from New to Open

Updated by Steven Puttemans almost 2 years ago

Actually, took a look at it and it seems that the actual test code in the sample directories was wrong. No idea how this got changed, since in the past it was actually correct. Replaced it again by the image loading example. Pull request can be found at: https://github.com/Itseez/opencv/pull/1842

  • % Done changed from 0 to 50
  • Assignee changed from Tim Regan to Kirill Kornyakov

Updated by Kirill Kornyakov almost 2 years ago

  • Affected version changed from 2.4.6 (latest release) to branch '2.4' (2.4-dev)
  • Pull request set to https://github.com/Itseez/opencv/pull/1842

Updated by Steven Puttemans almost 2 years ago

Fix merged, bug report closed.

  • % Done changed from 50 to 100
  • Affected version changed from branch '2.4' (2.4-dev) to 2.4.7 (latest release)
  • Assignee deleted (Kirill Kornyakov)
  • Status changed from Open to Done

Also available in: Atom PDF