introduction tutorial for windows is using the wrong constants (Bug #3314)


Added by be rak over 3 years ago. Updated over 3 years ago.


Status:Done Start date:2013-10-10
Priority:Low Due date:
Assignee:Kirill Kornyakov % Done:

100%

Category:documentation
Target version:Next Hackathon
Affected version:2.4.6 (latest release) Operating System:Any
Difficulty:Easy HW Platform:Any
Pull request:

Description

http://docs.opencv.org/trunk/doc/tutorials/introduction/windows_visual_studio_Opencv/windows_visual_studio_Opencv.html#test-it

is using the CAP_PROP_* flags from master(3.0), though it's targeted at 2.4.

all of them should be CV_CAP_PROP_* instead


History

Updated by Kirill Kornyakov over 3 years ago

  • Target version changed from 2.4.7 to Next Hackathon
  • Category changed from samples to documentation
  • Assignee deleted (Kirill Kornyakov)

Updated by Dmitry Retinskiy over 3 years ago

  • Status changed from New to Open

Updated by Steven Puttemans over 3 years ago

Actually I just pulled the latest 2.4 version on my system and it seems that it was already corrected

  Size refS = Size((int) captRefrnc.get(CV_CAP_PROP_FRAME_WIDTH),
                     (int) captRefrnc.get(CV_CAP_PROP_FRAME_HEIGHT)),
       uTSi = Size((int) captUndTst.get(CV_CAP_PROP_FRAME_WIDTH),
                     (int) captUndTst.get(CV_CAP_PROP_FRAME_HEIGHT));

I think that this could be closed. Probably the fixed isn't loaded into the proper documentation anymore.

  • Status changed from Open to Incomplete
  • Assignee set to Kirill Kornyakov

Updated by Steven Puttemans over 3 years ago

BTW your link contains 'trunk' in the link, if you leave that out and check the latest 2.4 docs you get it visualized correctly.

http://docs.opencv.org/doc/tutorials/introduction/windows_visual_studio_Opencv/windows_visual_studio_Opencv.html#test-it

Updated by Steven Puttemans over 3 years ago

  • Status changed from Incomplete to Done
  • % Done changed from 0 to 100

Also available in: Atom PDF