VideoWriter output with VP8 not working on Fedora and Ubuntu (Bug #3203)


Added by Jan Sedlák about 4 years ago. Updated about 2 years ago.


Status:Open Start date:2013-08-07
Priority:Normal Due date:
Assignee:Alexander Smorkalov % Done:

0%

Category:highgui-video
Target version:Next Hackathon
Affected version:2.4.0 - 2.4.5 Operating System:Linux
Difficulty: HW Platform:x64
Pull request:

Description

Hi, I have asked this question but no one answered it and I think that this is bug.

I want to use VideoWriter with webm output, I am using VP8 codec. It creates VideoWriter correctly and without an error. It creates output file and it puts information about resolution in it, but when I write image into it, it doesn't do anything and output file is always only 7 KiB. I have also tried it in C++ with the same result.

I am using Fedora 19, 64bit. I have added RPM Fusion repos and tried to install every gstreamer plugin, ffmpeg and everything that popped out when I searched "VP8". I also tried it in Ubuntu 13.04 with the same result. When I tried to use different codec (xvid), it worked.

You can try it with code I have pasted on answers.opencv.org.


History

Updated by Alexander Smorkalov about 4 years ago

  • Category set to highgui-video
  • Target version set to Next Hackathon
  • Assignee set to Alexander Smorkalov

Updated by Victor Kocheganov about 4 years ago

  • Status changed from New to Open

Updated by Maksim Shabunin about 2 years ago

Issue has been transferred to GitHub: https://github.com/Itseez/opencv/issues/4610

Also available in: Atom PDF