Problem reading .AVI file when migrating from openCV 2.1 to openCV2.4.1 (Bug #2115)


Added by Juergen Sienel over 4 years ago. Updated over 1 year ago.


Status:Open Start date:2012-06-29
Priority:Normal Due date:
Assignee:Vadim Pisarevsky % Done:

0%

Category:highgui-video
Target version:Next Hackathon
Affected version:branch '2.4' Operating System:
Difficulty: HW Platform:
Pull request:

Description

I am migrating an video application from OpenCv2.1 to 2.4.1. While opening and querying a capture opened with cvCaptureFromFile in 2.1 works well, the same program crashes when linked against 2.4.1 on windows XP.
I've tracked the problem down to CvCapture_FFMPEG_proxy::retrieveFrame, were see and assignment error icvRetrieveFrame_FFMPEG_p(ffmpegCapture, &data,...) when called on the first frame.


History

Updated by Juergen Sienel over 4 years ago

AVI file codec information: Codec: Planar 4:2.0 YUV (I420), resolution (352 * 288) Frame rate: 30

Updated by Andrey Kamaev over 4 years ago

  • Category changed from highgui-images to highgui-video

Updated by ZhiHeng NIU over 4 years ago

I encountered the same problem for OpenCV2.4.2. Crashed at icvRetrieveFrame_FFMPEG_p when read an AVI file.

Updated by Greg Phil over 4 years ago

I'm having the same problem. It seems to be a problem of the video size or even more an issue of the frame size.
I tried an uncompressed 8bit grayscale avi with 640x680, 39fps, 19frames ->works well.
But the cvRetrieveFrame_FFMPEG_p() is throwing an unhanded exception by using an uncompressed 8bit grayscale avi with 1920x1080, 25fps, 500frames.

By the way I'm using VC10 and x64.
cheers

Updated by Kirill Kornyakov over 4 years ago

Added to the 2.4.4, because multiple people report the problem.

Could somebody confirm, that the problem reproduces with OpenCV 2.4.3?

  • Target version set to 2.4.4

Updated by Francesco Leotta over 4 years ago

The problem still persists in OpenCV 2.4.9 64 bit. Windows 8. 320x240 color 20fps.

Updated by S K about 4 years ago

I am also getting the same issue in reading uncompressed avi file with OpenCV2.4.3rc with UYVY encoding.
I tried different video codec for encoding and V210 seems to work fine on 64 bit.

Thanks
Shikha

Updated by Vadim Pisarevsky about 4 years ago

  • Target version deleted (2.4.4)

Updated by Vadim Pisarevsky about 4 years ago

  • Assignee deleted (Vadim Pisarevsky)

Updated by Vadim Pisarevsky about 4 years ago

  • Assignee set to Vadim Pisarevsky

Updated by Kirill Kornyakov about 4 years ago

  • Target version set to 2.4.4
  • Affected version set to branch '2.4'

Updated by Andrey Kamaev about 4 years ago

  • Target version changed from 2.4.4 to Next Hackathon

Updated by Amaury Mortier about 4 years ago

Hi all!

I'm encoutering the same problem with OpenCV 2.4.4 (actually with OpenCV 2.4.2 too).
I could read a raw avi without problem with OpenCV 2.1 (features example of file: codecs: rawvideo, bgr24, 1920x1080, bitrate: 1000865 kb/s, duration 21 seconds). But now with the new version, as soon as I put the first frame of my VideoCapture in a Mat, it throws me an access violation exception, coming from mlock.c file.
I have no problem with xvid avi file for example.

Thanks.
M.

Updated by Vishnu Makkapati almost 2 years ago

I run into this issue while using 32 bit version of OpenCV 2.4.9 with Visual Studio 2010. The program crashes on the call to icvRetrieveFrame_FFMPEG_p. Is there a solution?

Updated by Maksim Shabunin over 1 year ago

Issue has been transferred to GitHub: https://github.com/Itseez/opencv/issues/4383

Also available in: Atom PDF